Returns a new isometric View3D.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the new View3D will be added.
- viewFamilyTypeId
- Type: Autodesk.Revit.DBElementId
The id of the ViewFamilyType which will be used by the new View3D. The type needs to be a ThreeDimensional ViewType.
Return Value
The new isometric View3D.Remarks
The new View3D will receive a unique view name. The view will be oriented in the same position as the default 3D view.
Examples

' Find a 3D view type
Dim collector1 As New FilteredElementCollector(document)
collector1 = collector1.OfClass(GetType(ViewFamilyType))
Dim viewFamilyTypes As IEnumerable(Of ViewFamilyType)
viewFamilyTypes = From elem In collector1 _
Let vftype = TryCast(elem, ViewFamilyType) _
Where vftype.ViewFamily = ViewFamily.ThreeDimensional _
Select vftype
' Create a new View3D
Dim view3D__1 As View3D = View3D.CreateIsometric(document, viewFamilyTypes.First().Id)
If view3D__1 IsNot Nothing Then
' By default, the 3D view uses a default orientation.
' Change the orientation by creating and setting a ViewOrientation3D
Dim eye As New XYZ(10, 10, 10)
Dim up As New XYZ(0, 1, 1)
Dim forward As New XYZ(0, 1, -1)
Dim viewOrientation3D As New ViewOrientation3D(eye, up, forward)
view3D__1.SetOrientation(viewOrientation3D)
End If
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This View Family Type is not a ThreeDimensional view type. -or- 3D view creation is not allowed in this family. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |