CreateAddInCommandBinding Method


Creates a new AddInCommandBinding.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2013

Syntax

C#
public AddInCommandBinding CreateAddInCommandBinding(
	RevitCommandId revitCommandId
)
Visual Basic
Public Function CreateAddInCommandBinding ( _
	revitCommandId As RevitCommandId _
) As AddInCommandBinding
Visual C++
public:
AddInCommandBinding^ CreateAddInCommandBinding(
	RevitCommandId^ revitCommandId
)

Parameters

revitCommandId
Type: Autodesk.Revit.UIRevitCommandId
The Revit command id to identify the command handler you want to replace.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullExceptionThrown when uiApplication or revitCommandId is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when the given command already has been bound.

See Also