Represents a specific type of wall, such as 'Generic - 8"'.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
All wall type objects available in the project can be retrieved from the Document object via the WallTypes property. Every Wall object has a WallType property that returns the a WallType object representing the type. This same WallType property can also be used to change the type of the wall by setting it to a different type.
Examples

public void GetInfo_WallType(WallType wallType)
{
string message;
// Reports the nature of the wall
message = "The wall type kind is : " + wallType.Kind.ToString();
// Get the overall thickness of this type of wall.
message += "\nThe wall type Width is : " + wallType.Width.ToString();
TaskDialog.Show("Revit",message);
}

Public Sub GetInfo_WallType(wallType As WallType)
Dim message As String
' Reports the nature of the wall
message = "The wall type kind is : " & wallType.Kind.ToString()
' Get the overall thickness of this type of wall.
message += vbLf & "The wall type Width is : " & wallType.Width.ToString()
TaskDialog.Show("Revit", message)
End Sub
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallType
Autodesk.Revit.DBElement
Autodesk.Revit.DBElementType
Autodesk.Revit.DBHostObjAttributes
Autodesk.Revit.DBWallType