GetHookLength Method


Identifies the hook length for a hook type

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
public double GetHookLength(
	ElementId hookId
)
Visual Basic
Public Function GetHookLength ( _
	hookId As ElementId _
) As Double
Visual C++
public:
double GetHookLength(
	ElementId^ hookId
)

Parameters

hookId
Type: Autodesk.Revit.DBElementId
id of the hook type

Return Value

The hook length for a hook type

Remarks

If the AutoCalcHookLengths property is turned off, the default hook length will be returned

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException the rebar hook type id hookId is not valid
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also