SetRodEndPosition Method


Sets the position of the rod end. The method is applicable only for bearer hanger.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void SetRodEndPosition(
	int rodIndex,
	XYZ position
)
Visual Basic
Public Sub SetRodEndPosition ( _
	rodIndex As Integer, _
	position As XYZ _
)
Visual C++
public:
void SetRodEndPosition(
	int rodIndex, 
	XYZ^ position
)

Parameters

rodIndex
Type: SystemInt32
The index of the rod.
position
Type: Autodesk.Revit.DBXYZ
The position of the rod end.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Invalid rod position.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException the index rodIndex is should be in range of rod count.
Autodesk.Revit.ExceptionsInvalidOperationException The hanger is not a bearer hanger.

See Also