WorksetKindFilter Constructor (WorksetKind, Boolean)


Constructs a new instance of WorksetKindFilter filter to match worksets of the given WorksetKind.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public WorksetKindFilter(
	WorksetKind worksetKind,
	bool inverted
)
Visual Basic
Public Sub New ( _
	worksetKind As WorksetKind, _
	inverted As Boolean _
)
Visual C++
public:
WorksetKindFilter(
	WorksetKind worksetKind, 
	bool inverted
)

Parameters

worksetKind
Type: Autodesk.Revit.DBWorksetKind
The WorksetKind to match.
inverted
Type: SystemBoolean
True if the filter should match all worksets which are not of the given WorksetKind.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also