OperationCanceledException Class


The exception that is thrown when an operation is unexpectedly cancelled.

Namespace: Autodesk.Revit.Exceptions
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)

Syntax

C#
[SerializableAttribute]
public class OperationCanceledException : ApplicationException
Visual Basic
<SerializableAttribute> _
Public Class OperationCanceledException _
	Inherits ApplicationException
Visual C++
[SerializableAttribute]
public ref class OperationCanceledException : public ApplicationException

Inheritance Hierarchy

SystemObject
  SystemException
    Autodesk.Revit.ExceptionsApplicationException
      Autodesk.Revit.ExceptionsOperationCanceledException

See Also