GetSketchCurves Method


Populates the array with copies of curves in the sketch.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void GetSketchCurves(
	out IList<Curve> curveArray
)
Visual Basic
Public Sub GetSketchCurves ( _
	<OutAttribute> ByRef curveArray As IList(Of Curve) _
)
Visual C++
public:
void GetSketchCurves(
	[OutAttribute] IList<Curve^>^% curveArray
)

Parameters

curveArray
Type: System.Collections.GenericIListCurve%
Curves in the sketch. Tags of the curves are consistent with the curve tags used in part keys.

See Also