Returns a global parameter, if any, currently associated with this parameter.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
Id of a global parameter or InvalidElemetnId.Remarks
InvalidElementId is returned in case this parameter is not associated with any global parameter. InvalidElementId is also returned if called for a parameter that cannot even be associated with a global parameters (i.e. a non-parametrizable parameter or parameter with a formula).
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | This parameter does not exist in the document anymore. |