AddSize Method


Adds a new MEPSize to the segment.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public void AddSize(
	MEPSize size
)
Visual Basic
Public Sub AddSize ( _
	size As MEPSize _
)
Visual C++
public:
void AddSize(
	MEPSize^ size
)

Parameters

size
Type: Autodesk.Revit.DBMEPSize
The new MEPSize to be added.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException There is already a same size in the settings. -or- The size already exists in the segment.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also