Revision Class


Represents a single revision in the project.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public class Revision : Element
Visual Basic
Public Class Revision _
	Inherits Element
Visual C++
public ref class Revision : public Element

Remarks

The Revision object represents the data related to a single revision in the project. Revision clouds and tags can be associated with a particular Revision object to display its properties on sheets.

The revisions in the project are stored in a specific order called the revision sequence. The revision sequence represents the conceptual sequence in which revisions will be issued.

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DBRevision

See Also