Creates a new sheet assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DBElementId
Id of the assembly instance that owns the new view.
- titleBlockId
- Type: Autodesk.Revit.DBElementId
Id of the titleblock family to use. For no titleblock, pass invalidElementId.
Return Value
A new sheet assembly view.Remarks
The document must be regenerated before using the sheet.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- titleBlockId is not a TitleBlock. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |