This class represents the MEP design to fabrication part convert tool.
Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
After a new instance of the class is created, call the Convert method to convert the MEP design elements into fabrication parts. Use the method SetMapForFamilySymbolToFabricationPartType to optionally convert family content to fabrication parts prior to calling Convert by providing a mapping of family symbols to fabrication parts types. If not set, then during conversion these families will remain and any connections to other converted elements will be maintained. After the convert method has been invoked, query the class to obtain more information about the conversion:
- GetConvertedFabricationParts to get a set of element identifiers for the newly created fabrication parts.
- GetElementsWithOpenConnector to get a set of fabrication part or MEP design element identifiers with open connectors, caused by fittings failing to convert.
Inheritance Hierarchy
SystemObject
Autodesk.Revit.DB.FabricationDesignToFabricationConverter
Autodesk.Revit.DB.FabricationDesignToFabricationConverter