Gets fabrication ancillaries of the specified type.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017 Subscription Update
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- type
- Type: Autodesk.Revit.DB.FabricationFabricationAncillaryType
The type of ancillaries to get.
- includeKits
- Type: SystemBoolean
Whether or not to include ancillary kits as well.
- filterKits
- Type: SystemBoolean
Whether kits should be filtered to only those that contain the specified ancillary type.
Return Value
An array of ancillary identifiers.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |