IsCreatedPhaseOrderValid Method


Returns true if createdPhaseId and demolishedPhaseId are in order.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public bool IsCreatedPhaseOrderValid(
	ElementId createdPhaseId
)
Visual Basic
Public Function IsCreatedPhaseOrderValid ( _
	createdPhaseId As ElementId _
) As Boolean
Visual C++
public:
bool IsCreatedPhaseOrderValid(
	ElementId^ createdPhaseId
)

Parameters

createdPhaseId
Type: Autodesk.Revit.DBElementId
The createdPhaseId.

Return Value

True if createdPhaseId index is less than or equal to demolishedPhaseId, otherwise returns false.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also