GetCurrentBrowserOrganizationForSchedules Method


Gets the BrowserOrganization that applies to the Schedules section of the project browser.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.1

Syntax

C#
public static BrowserOrganization GetCurrentBrowserOrganizationForSchedules(
	Document document
)
Visual Basic
Public Shared Function GetCurrentBrowserOrganizationForSchedules ( _
	document As Document _
) As BrowserOrganization
Visual C++
public:
static BrowserOrganization^ GetCurrentBrowserOrganizationForSchedules(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
Revit document from which to get the organization data.

Return Value

The BrowserOrganization for schedules, or null if no schedules sections exist

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also