CreateNumericSequence Method


Creates a new numeric revision numbering sequence in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2022

Syntax

C#
public static RevisionNumberingSequence CreateNumericSequence(
	Document document,
	string name,
	NumericRevisionSettings settings
)
Visual Basic
Public Shared Function CreateNumericSequence ( _
	document As Document, _
	name As String, _
	settings As NumericRevisionSettings _
) As RevisionNumberingSequence
Visual C++
public:
static RevisionNumberingSequence^ CreateNumericSequence(
	Document^ document, 
	String^ name, 
	NumericRevisionSettings^ settings
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document of the new revision numbering sequence.
name
Type: SystemString
The name for the revision numbering sequence.
settings
Type: Autodesk.Revit.DBNumericRevisionSettings
The numeric settings for the revision numbering sequence.

Return Value

The newly created revision numbering sequence.

Remarks

The new revision numbering sequence will not be assigned to any revision. Use `Revision.SetRevisionNumberingSequenceId` to apply the sequence to a revision.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException document is not a project document. -or- name is an empty string or contains only whitespace. -or- name cannot include prohibited characters, such as "{, }, [, ], |, ;, less-than sign, greater-than sign, ?, `, ~". -or- settings is not a valid NumericRevisionSettings.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements).
Autodesk.Revit.ExceptionsModificationForbiddenException The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process.
Autodesk.Revit.ExceptionsModificationOutsideTransactionException The document has no open transaction.

See Also