BRepBuilder Constructor


Construct a BRepBuilder to use in constructing geometry.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public BRepBuilder(
	BRepType geomType
)
Visual Basic
Public Sub New ( _
	geomType As BRepType _
)
Visual C++
public:
BRepBuilder(
	BRepType geomType
)

Parameters

geomType
Type: Autodesk.Revit.DBBRepType
Specifies the expected type of the output geometry.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also