CheckServiceType Method


Checks that the service type falls within an appropriate range.

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public static bool CheckServiceType(
	gbXMLServiceType serviceType
)
Visual Basic
Public Shared Function CheckServiceType ( _
	serviceType As gbXMLServiceType _
) As Boolean
Visual C++
public:
static bool CheckServiceType(
	gbXMLServiceType serviceType
)

Parameters

serviceType
Type: Autodesk.Revit.DB.AnalysisgbXMLServiceType
The service type to be checked.

Return Value

True if the service type falls within an appropriate range, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also