BringToFront Method (Document, View, ICollection(ElementId))


Places the given detail instances in the front of all other detail instances in the view, while keeping the order of the given ones.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public static void BringToFront(
	Document document,
	View view,
	ICollection<ElementId> detailElementIds
)
Visual Basic
Public Shared Sub BringToFront ( _
	document As Document, _
	view As View, _
	detailElementIds As ICollection(Of ElementId) _
)
Visual C++
public:
static void BringToFront(
	Document^ document, 
	View^ view, 
	ICollection<ElementId^>^ detailElementIds
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document.
view
Type: Autodesk.Revit.DBView
The view in which the details appear.
detailElementIds
Type: System.Collections.GenericICollectionElementId
The details to bring to front.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The document does not support detail draw order. Only projects and 3d families support draw order. 2d families and in-place families do not support draw order. -or- detailElementIds is empty or it contains elements that do not participate in detail draw ordering. Details must be visible in the view. -or- In 3d families, detail draw order can only be adjusted in views that are parallel to the document's X, Y or Z axes.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also