Creates a fascia along a reference.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- FasciaType
- Type: Autodesk.Revit.DB.ArchitectureFasciaType
The type of the fascia to create
- reference
- Type: Autodesk.Revit.DBReference
A planar line or arc that represents the place where you want to place the fascia.
Return Value
If successful a new fascia object within the project, otherwise a null reference (Nothing in Visual Basic).Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | Thrown if the fascia type does not exist in the given document. |