Get the Geometry object built by this BRepBuilder. This will clear the built Geometry stored in the BRepBuilder. This function will throw if this BRepBuilder hasn't completed building the b-rep. Use IsResultAvailable() to verify that this BRepBuilder contains a valid result.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalId
- Type: Autodesk.Revit.DBExternalGeometryId
The external Id of the Geometry object built by this BRepBuilder.
- brepPersistentIds
- Type: Autodesk.Revit.DBBRepBuilderPersistentIds
An object storing the relationship between ExternalGeometryIds and BRepBuilderGeometryIds.
Return Value
The Geometry object built by this BRepBuilder.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | At least one BRepBuilderGeometryId in the supplied BRepBuilderPersistentIds map could not be found in this BRepBuilder object. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | This BRepBuilder object hasn't completed building data or was unsuccessful building it. Built Geometry is unavailable. In order to access the built Geometry, Finish() must be called first. That will set the state to completed. |