SupportNumber Property


The number of supports of the handrail.

Namespace: Autodesk.Revit.DB.Architecture
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public int SupportNumber { get; set; }
Visual Basic
Public Property SupportNumber As Integer
	Get
	Set
Visual C++
public:
property int SupportNumber {
	int get ();
	void set (int value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The given value for supportNumber is negative.
Autodesk.Revit.ExceptionsInvalidOperationException When setting this property: The rail has no support or the support layout is not fixed number so the data being set is not applicable.

See Also