UnlabelDimension Method


Unlabels a dimension that is currently labeled by this global parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016 Subscription Update

Syntax

C#
public void UnlabelDimension(
	ElementId dimensionId
)
Visual Basic
Public Sub UnlabelDimension ( _
	dimensionId As ElementId _
)
Visual C++
public:
void UnlabelDimension(
	ElementId^ dimensionId
)

Parameters

dimensionId
Type: Autodesk.Revit.DBElementId
Id of a dimension element.

Remarks

It is assumed that the given dimension element is presently labeled by this parameter. If it is not, this method throws an exception.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException Given element Id is not of a valid dimension element. -or- The given dimension (dimensionId) is not labeled by this global parameter.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also