AnalyticalPanel Class


An element that represents a surface in the Structural Analytical Model.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2023

Syntax

C#
public class AnalyticalPanel : AnalyticalSurfaceBase
Visual Basic
Public Class AnalyticalPanel _
	Inherits AnalyticalSurfaceBase
Visual C++
public ref class AnalyticalPanel : public AnalyticalSurfaceBase

Inheritance Hierarchy

SystemObject
  Autodesk.Revit.DBElement
    Autodesk.Revit.DB.StructureAnalyticalElement
      Autodesk.Revit.DB.StructureAnalyticalSurfaceBase
        Autodesk.Revit.DB.StructureAnalyticalPanel

See Also