AddCommandLink Method (TaskDialogCommandLinkId, String, String)


Adds a CommandLink associated to the given id, displaying the indicating main and supporting content.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2011

Syntax

C#
public void AddCommandLink(
	TaskDialogCommandLinkId id,
	string mainContent,
	string supportingContent
)
Visual Basic
Public Sub AddCommandLink ( _
	id As TaskDialogCommandLinkId, _
	mainContent As String, _
	supportingContent As String _
)
Visual C++
public:
void AddCommandLink(
	TaskDialogCommandLinkId id, 
	String^ mainContent, 
	String^ supportingContent
)

Parameters

id
Type: Autodesk.Revit.UITaskDialogCommandLinkId
The id of the CommandLink. This corresponds to the value returned by Show() when the link is chosen by the user.
mainContent
Type: SystemString
The main content of the CommandLink.
supportingContent
Type: SystemString
The main content of the CommandLink.

Remarks

Parameter mainContent cannot contain newlines.

If the id has already been set to the task dialog, the new CommandLink definition overrides the old one.

CommandLinks will always be shown in the dialog in the order of their ids.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException Thrown when mainContent is a null reference (Nothing in Visual Basic).
Autodesk.Revit.ExceptionsArgumentException Thrown when mainContent is an empty string.
Autodesk.Revit.ExceptionsArgumentException Thrown when the mainContent contains newline characters.

See Also