GetRoomIds Method


Retrieves room ElementIds of the PlanTopology in the last phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 21.0.0.0 (21.1.1.109)
Since: 2013

Syntax

C#
public ICollection<ElementId> GetRoomIds()
Visual Basic
Public Function GetRoomIds As ICollection(Of ElementId)
Visual C++
public:
ICollection<ElementId^>^ GetRoomIds()

Return Value

The PlanTopology Room ElementIds of the last phase.

Remarks

The Rooms Ids returned are in the phase of PlanTopology and the current design option.

See Also