UpdaterId Constructor


creates an instance of UpdaterId for given AddInId and a given GUID value

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public UpdaterId(
	AddInId addInId,
	Guid val
)
Visual Basic
Public Sub New ( _
	addInId As AddInId, _
	val As Guid _
)
Visual C++
public:
UpdaterId(
	AddInId^ addInId, 
	Guid val
)

Parameters

addInId
Type: Autodesk.Revit.DBAddInId
Id of addin that registers an Updater
val
Type: SystemGuid
a GUID identifying the Updater within addin

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException addInId is not valid.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also