SetLinePatternId Method


Sets the line pattern id associated with this category for the given graphics style type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void SetLinePatternId(
	ElementId linePatternId,
	GraphicsStyleType graphicsStyleType
)
Visual Basic
Public Sub SetLinePatternId ( _
	linePatternId As ElementId, _
	graphicsStyleType As GraphicsStyleType _
)
Visual C++
public:
void SetLinePatternId(
	ElementId^ linePatternId, 
	GraphicsStyleType graphicsStyleType
)

Parameters

linePatternId
Type: Autodesk.Revit.DBElementId
The line pattern id for the graphics style.
graphicsStyleType
Type: Autodesk.Revit.DBGraphicsStyleType
The type of graphics style.

Remarks

  • The line pattern id will be one of the following:
  • A negative value (representing a built-in line pattern); this value can only be obtained via GetLinePatternId
  • The id of a LinePatternElement

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException Thrown when the input argument "linePatternId" is an illegal id.
Autodesk.Revit.ExceptionsInvalidOperationException Thrown when this category does not have stored line pattern id for this graphics style type.

See Also