GetMesh Method


This returns a valid mesh only for the first call. Later calls will throw an exception as the mesh is no longer valid in this object.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public Mesh GetMesh()
Visual Basic
Public Function GetMesh As Mesh
Visual C++
public:
Mesh^ GetMesh()

Return Value

Mesh which built.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException The Mesh has already been accessed by a previous GetMesh() call, and is no longer available for use.

See Also