RectangleLightShape Constructor (RectangleLightShape)


Creates a copy of the given rectangle light shape

Namespace: Autodesk.Revit.DB.Lighting
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2013

Syntax

C#
public RectangleLightShape(
	RectangleLightShape other
)
Visual Basic
Public Sub New ( _
	other As RectangleLightShape _
)
Visual C++
public:
RectangleLightShape(
	RectangleLightShape^ other
)

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also