AddVertex Method


Inserts a VertexStreamPosition into the stream and associated buffer.

Namespace: Autodesk.Revit.DB.DirectContext3D
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2017

Syntax

C#
public void AddVertex(
	VertexPosition vertex
)
Visual Basic
Public Sub AddVertex ( _
	vertex As VertexPosition _
)
Visual C++
public:
void AddVertex(
	VertexPosition^ vertex
)

Parameters

vertex
Type: Autodesk.Revit.DB.DirectContext3DVertexPosition
The vertex to be inserted.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsInvalidOperationException Thrown if the associated buffer is not mapped. -or- Thrown if the associated buffer has insufficient space.

See Also