GetFillPatternElementByName Method


Retrieves the FillPatternElement by its name.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public static FillPatternElement GetFillPatternElementByName(
	Document document,
	FillPatternTarget target,
	string name
)
Visual Basic
Public Shared Function GetFillPatternElementByName ( _
	document As Document, _
	target As FillPatternTarget, _
	name As String _
) As FillPatternElement
Visual C++
public:
static FillPatternElement^ GetFillPatternElementByName(
	Document^ document, 
	FillPatternTarget target, 
	String^ name
)

Parameters

document
Type: Autodesk.Revit.DBDocument
The document in which to retrieve the FillPatternElement.
target
Type: Autodesk.Revit.DBFillPatternTarget
The FillPatternTarget of the FillPatternElement.
name
Type: SystemString
The name of the FillPatternElement.

Return Value

The FillPatternElement.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException target must be Model or Drafting.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also