FabricationNetworkChangeService Constructor


Creates a new instance of the FabricationNetworkChangeService class.

Namespace: Autodesk.Revit.DB.Fabrication
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2018.2

Syntax

C#
public FabricationNetworkChangeService(
	Document document
)
Visual Basic
Public Sub New ( _
	document As Document _
)
Visual C++
public:
FabricationNetworkChangeService(
	Document^ document
)

Parameters

document
Type: Autodesk.Revit.DBDocument
A document in which to change the service or size of the selected fabrication parts.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also