Roughness Property


The roughness of Duct Lining.

Namespace: Autodesk.Revit.DB.Mechanical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public double Roughness { get; set; }
Visual Basic
Public Property Roughness As Double
	Get
	Set
Visual C++
public:
property double Roughness {
	double get ();
	void set (double value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException When setting this property: The roughness value should be at least equal to or larger than 0.
Autodesk.Revit.ExceptionsDisabledDisciplineException When setting this property: None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also