CanAddEntry Method


Verifies if the KeyBasedTreeEntry could be added in this KeyBasedTreeEntriesLoadContent.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2015

Syntax

C#
public bool CanAddEntry(
	KeyBasedTreeEntry entry
)
Visual Basic
Public Function CanAddEntry ( _
	entry As KeyBasedTreeEntry _
) As Boolean
Visual C++
public:
bool CanAddEntry(
	KeyBasedTreeEntry^ entry
)

Parameters

entry
Type: Autodesk.Revit.DBKeyBasedTreeEntry
The KeyBasedTreeEntry object to be checked.

Return Value

True if the KeyBasedTreeEntry could be added in, otherwise false.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also