GetMacro Method


Gets the macro with the give name.

Namespace: Autodesk.Revit.DB.Macros
Assembly: RevitAPIMacros (in RevitAPIMacros.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public Macro GetMacro(
	string name
)
Visual Basic
Public Function GetMacro ( _
	name As String _
) As Macro
Visual C++
public:
Macro^ GetMacro(
	String^ name
)

Parameters

name
Type: SystemString
The macro name.

Return Value

The macro.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also