ListFields Method


The complete list of fields in the Schema, sorted by name.

Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2012

Syntax

C#
public IList<Field> ListFields()
Visual Basic
Public Function ListFields As IList(Of Field)
Visual C++
public:
IList<Field^>^ ListFields()

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsInvalidOperationException Reading of Entities of this Schema is not allowed to the current add-in.

See Also