Creates a new part list multicategory schedule assembly view for the assembly instance.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document to which the view will be added.
- assemblyInstanceId
- Type: Autodesk.Revit.DBElementId
Id of the assembly instance that owns the new view.
- viewTemplateId
- Type: Autodesk.Revit.DBElementId
Id of the view template that is used to create the view; if invalidElementId, the view will be created with the default settings.
- isAssigned
- Type: SystemBoolean
If true, the template will be assigned, if false, the template will be applied.
Return Value
A new part list multicategory schedule assembly view.Remarks
The new part list schedule will be preloaded with fields "Category", "Family and Type" and "Count". The document must be regenerated before using the schedule.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | assemblyInstanceId is not an AssemblyInstance. -or- viewTemplateId is not a correct view template for the schedule view. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsModificationForbiddenException | The document is in failure mode: an operation has failed, and Revit requires the user to either cancel the operation or fix the problem (usually by deleting certain elements). -or- The document is being loaded, or is in the midst of another sensitive process. |
Autodesk.Revit.ExceptionsModificationOutsideTransactionException | The document has no open transaction. |