HasBubbleInView Method


Identifies if the DatumPlane has bubble or not.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2016

Syntax

C#
public bool HasBubbleInView(
	DatumEnds datumEnd,
	View view
)
Visual Basic
Public Function HasBubbleInView ( _
	datumEnd As DatumEnds, _
	view As View _
) As Boolean
Visual C++
public:
bool HasBubbleInView(
	DatumEnds datumEnd, 
	View^ view
)

Parameters

datumEnd
Type: Autodesk.Revit.DBDatumEnds
The end of the datum plane.
view
Type: Autodesk.Revit.DBView
The view on which the DatumPlane shows.

Return Value

True if the DatumPlane has bubble, false otherwise.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration
Autodesk.Revit.ExceptionsInvalidOperationException This datum plane doesn't support bubble operations.

See Also