GetLocation Method


Returns the location of one of the points of the ImageInstance

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2020

Syntax

C#
public XYZ GetLocation(
	BoxPlacement placementPoint
)
Visual Basic
Public Function GetLocation ( _
	placementPoint As BoxPlacement _
) As XYZ
Visual C++
public:
XYZ^ GetLocation(
	BoxPlacement placementPoint
)

Parameters

placementPoint
Type: Autodesk.Revit.DBBoxPlacement
The placementPoint specifies for which point of the ImageInstance the location should be returned.

Return Value

The location of the specified point

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentOutOfRangeException A value passed for an enumeration argument is not a member of that enumeration

See Also