Connects two placeholders that looks like Tee connection.
Namespace: Autodesk.Revit.DB.Plumbing
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- placeholder1Id
- Type: Autodesk.Revit.DBElementId
The first element Id of pipe placeholder.
- placeholder2Id
- Type: Autodesk.Revit.DBElementId
The second element Id of pipe placeholder which connects to first.
Return Value
True if connection succeeds, false otherwise.Remarks
The second placeholder must have physically connection with the first one. If connection fails, the placeholders cannot be physically connected.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | The element id placeholder1Id is not pipe placeholder. -or- The element id placeholder2Id is not pipe placeholder. -or- The elements belong to different types of system. -or- The curve placeholder2Id does not connect on the curve placeholder1Id or vice versa. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |