AnalyticalModelSelector Constructor (Curve)


Creates a selector based on a specific analytical curve.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public AnalyticalModelSelector(
	Curve curve
)
Visual Basic
Public Sub New ( _
	curve As Curve _
)
Visual C++
public:
AnalyticalModelSelector(
	Curve^ curve
)

Parameters

curve
Type: Autodesk.Revit.DBCurve
The curve upon which this selector acts.

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException The input curve points to a helical curve and is not supported for this operation.
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also