Creates a new shared parameter element in the document representing the parameter stored in the input ExternalDefinition.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DBDocument
The document.
- sharedParameterDefinition
- Type: Autodesk.Revit.DBExternalDefinition
Shared parameter definition.
Return Value
The newly created shared parameter instance.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | A shared parameter with the assigned GUID is already loaded into the document. |