Returns a stable reference to the start or the end point of the edge.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- index
- Type: SystemInt32
Use 0 for the start point; 1 for the end point.
Return Value
Reference to the point or a null reference (Nothing in Visual Basic) if reference cannot be obtained.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | Thrown when the specified index is not 0 or 1. |
Autodesk.Revit.ExceptionsInvalidOperationException | Thrown when the object is internally marked as read-only in the setter. |