LineStyleId Property


Identifies the line style that is used for drawing Bending Detail curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2024

Syntax

C#
public ElementId LineStyleId { get; set; }
Visual Basic
Public Property LineStyleId As ElementId
	Get
	Set
Visual C++
public:
property ElementId^ LineStyleId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentException When setting this property: The lineStyleId should be an id of a line style.
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null

See Also