FieldDomainPointsByParameter Constructor


Creates object from an array of one-dimensional point coordinates

Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2011

Syntax

C#
public FieldDomainPointsByParameter(
	IList<double> points
)
Visual Basic
Public Sub New ( _
	points As IList(Of Double) _
)
Visual C++
public:
FieldDomainPointsByParameter(
	IList<double>^ points
)

Parameters

points
Type: System.Collections.GenericIListDouble
Array of one-dimensional point coordinates representing domain points (using raw parameters when on a curve)

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException A non-optional argument was null

See Also