Adds a correspondence between an ExternalGeometryId and a BRepBuilderGeometryId. Note that an existing correspondence in the map cannot be updated and that a particular BRepBuilderGeometryId may be related to at most one ExternalGeometryId.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2022
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- externalGeometryId
- Type: Autodesk.Revit.DBExternalGeometryId
An external geometry object Id.
- brepBuilderGeometryId
- Type: Autodesk.Revit.DBBRepBuilderGeometryId
A BRepBuilder geometry object Id. It must represent the ID of either a Face or an Edge.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | externalGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it is already used. -or- brepBuilderGeometryId cannot be used to create a new correspondence because it doesn't represent the ID of either a Face or an Edge. |
Autodesk.Revit.ExceptionsArgumentNullException | A non-optional argument was null |
Autodesk.Revit.ExceptionsInvalidOperationException | The associated BRepBuilder doesn't exist or is not valid (has no Faces and no Edges). |