Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since: 2020
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Remarks
If LockProportions is true, then changes to the WidthScale will also result in changes to the HeightScale.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.ExceptionsArgumentException | When setting this property: The given value for widthScale results in a width that is more than 30000 feet. -or- When setting this property: The given value for widthScale results in a height that is more than 30000 feet because LockProportions is set to true. |
Autodesk.Revit.ExceptionsArgumentOutOfRangeException | When setting this property: The given value for widthScale must be non-negative. |