CurveNormal Property


The up-direction vector of the cable tray.

Namespace: Autodesk.Revit.DB.Electrical
Assembly: RevitAPI (in RevitAPI.dll) Version: 24.0.0.0 (24.0.0.0)
Since:  2014

Syntax

C#
public XYZ CurveNormal { get; set; }
Visual Basic
Public Property CurveNormal As XYZ
	Get
	Set
Visual C++
public:
property XYZ^ CurveNormal {
	XYZ^ get ();
	void set (XYZ^ value);
}

Exceptions

ExceptionCondition
Autodesk.Revit.ExceptionsArgumentNullException When setting this property: A non-optional argument was null
Autodesk.Revit.ExceptionsDisabledDisciplineException None of the following disciplines is enabled: Mechanical Electrical Piping.

See Also